mysqld not running after upgrade from 15.8 -to 16.3

Scrutinizer is an enterprise/business class NetFlow and sFlow analysis tool. Scrutinizer provides historical trends of the company's critical network interfaces as well as the details on:

Who: The end system causing the traffic
What: The application/protocol that is being used
When: The time frame it has been occurring for
Where: The network connection that is affected

Moderators: scottr, Moderator Team

Post Reply
biera16
Posts: 3
Joined: Thu Dec 01, 2016 12:38 am

mysqld not running after upgrade from 15.8 -to 16.3

Post by biera16 » Thu Dec 01, 2016 1:53 am

Hi

I started off with a Linux install running perfectly fine on 12.1.
Since it was such an old installation I decided to patch it according to https://forums.plixer.com/viewtopic.php ... 9127#p9127 which mentions the 12.1 -> 15.5 -> 15.8 -> 16.3 -> 16.11 migration path. I got as far as upgrading
12.1 -> 15.5
15.5 -> 15.8
But after I upgraded 15.8 to 16.3 the mysql stopped working. I am no expert but it appears the mysql server is no longer running.

Code: Select all

[root@scrutinizer ~]# /home/plixer/scrutinizer/bin/scrut_util.exe -update_plixerini_mysqlroot

Scrutinizer 16.3.28.58672 (Mon Mar 28 16:44:42 2016)
scrut_util 16.3.28.58553 (2016-03-22 18:52:31 -0400 (Tue, 22 Mar 2016))

*** not tested on linux appliance ***



Update plixer.ini db root password
==================================

Note: This command will not change the database root password. If you wish to
change the password, execute scrut_util.exe -reset_mysql_password

The Plixer Database Service is currently not running. Please start the
service and re-run this command.

Code: Select all

[root@scrutinizer ~]# ps aux | grep -i sql
root      3116  0.0  0.0 103312   912 pts/1    S+   01:49   0:00 grep -i sql
[root@scrutinizer ~]#
Looks like mysql has been removed?

Code: Select all

[root@scrutinizer ~]# chkconfig | grep -i sql

How do I verify this?

best regards
Arne

jennm
Posts: 6
Joined: Thu Jun 09, 2016 11:36 am

Re: mysqld not running after upgrade from 15.8 -to 16.3

Post by jennm » Thu Dec 01, 2016 9:26 am

Hello Arne,

It sounds like the MariaDB service did not kick off after installing 16.3. Try running 'service plixer_db start' on the command line.

If this does not solve you issue please reply to this post with the last 50 lines of your install log found here:

Code: Select all

/home/plixer/scrutinizer/files/Scrutinizer-installLog.txt 
Thanks!

Jenn

biera16
Posts: 3
Joined: Thu Dec 01, 2016 12:38 am

Re: mysqld not running after upgrade from 15.8 -to 16.3

Post by biera16 » Thu Dec 01, 2016 3:30 pm

Hi Jenn

thanks for the reply.

Code: Select all

[root@scrutinizer ~]# service plixer_db start
plixer_db: unrecognized service
Here are the last 50 lines of the install.log

Code: Select all

[root@scrutinizer files]# tail -50 /home/plixer/scrutinizer/files/Scrutinizer-installLog.txt
tail: cannot open `/home/plixer/scrutinizer/files/Scrutinizer-installLog.txt' for reading: No such file or directory

[root@scrutinizer files]# tail -50 /home/plixer/scrutinizer/files/install.log
 deleting collation-server
 deleting collation-server
 adding collation-server=utf8_general_ci to mysqld
 elapsed_time:1.299728
    - /home/mysql/data/tmp/ was missing, creating it
 elapsed_time:1.3065
+ updating ini file: /etc/my.cnf

 deleting slow_query_log
 changing value for interactive_timeout to 600
 changing value for wait_timeout to 600
 changing value for log_queries_not_using_indexes to OFF
 adding group_concat_max_len=4096 to mysqld* group_concat_max_len = 4096 already exists
 adding partition=OFF to mysqld* partition = OFF already exists
 elapsed_time:0.034977
Cleaning up extra options in /usr/my.cnf
+ updating ini file: /usr/my.cnf

 deleting sql_mode
 deleting sql-mode
 deleting sql_mode
 deleting sql-mode
 elapsed_time:0.020367
+ updating ini file: /etc/plixer.ini

 changing value for temp to 1024
 changing value for heap to 512
 changing value for sort to 512
 changing value for temp to 1024
 elapsed_time:0.021973
+ updating ini file: /etc/my.cnf

 changing value for max_allowed_packet to 64M
 deleting skip_name_resolve
 elapsed_time:0.029622
+ updating ini file: /usr/my.cnf

 deleting sql_mode
 elapsed_time:0.013872- Removing mysql
- Installing maria
- Using internet install
- Repairing all databases

+ Adding customized mysql functions (installer::common::my_conf_functions)

  parameter pwd => *******
  parameter details => HASH(0x74edde8)
  parameter conf => /etc/my.cnf

  - running: DROP FUNCTION IF EXISTS stat_accum_int
  [root@scrutinizer files]#
It appears Maria-DB didn't install - I went ahead and installed it to the best of my knowledge - but I don't know how to start it.

Code: Select all

[root@scrutinizer ~]# rpm -qa | grep -i maria

[root@scrutinizer ~]# yum list | grep MariaDB-server
MariaDB-server.x86_64                      10.0.28-1.el6                mariadb

[root@scrutinizer ~]# yum list | grep MariaDB-client
MariaDB-client.x86_64                      10.0.28-1.el6                mariadb

[root@scrutinizer ~]# yum install MariaDB-server MariaDB-client
Loaded plugins: fastestmirror, presto
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.overthewire.com.au
 * epel: ucmirror.canterbury.ac.nz
 * extras: mirror.overthewire.com.au
 * rpmforge: mirror.hmc.edu
 * updates: mirror.overthewire.com.au
Resolving Dependencies
--> Running transaction check
---> Package MariaDB-client.x86_64 0:10.0.28-1.el6 will be installed
--> Processing Dependency: MariaDB-common for package: MariaDB-client-10.0.28-1.el6.x86_64
---> Package MariaDB-server.x86_64 0:10.0.28-1.el6 will be installed
--> Running transaction check
---> Package MariaDB-common.x86_64 0:10.0.28-1.el6 will be installed
--> Processing Dependency: MariaDB-compat for package: MariaDB-common-10.0.28-1.el6.x86_64
--> Running transaction check
---> Package MariaDB-compat.x86_64 0:10.0.28-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================================================================================
 Package                                 Arch                            Version                                   Repository                        Size
==========================================================================================================================================================
Installing:
 MariaDB-client                          x86_64                          10.0.28-1.el6                             mariadb                           11 M
 MariaDB-server                          x86_64                          10.0.28-1.el6                             mariadb                           58 M
Installing for dependencies:
 MariaDB-common                          x86_64                          10.0.28-1.el6                             mariadb                           41 k
 MariaDB-compat                          x86_64                          10.0.28-1.el6                             mariadb                          2.7 M

Transaction Summary
==========================================================================================================================================================
Install       4 Package(s)

Total size: 72 M
Total download size: 58 M
Installed size: 297 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 58 M
MariaDB-10.0.28-centos6-x86_64-server.rpm                                                                                                                                                                             |  58 MB     02:57
warning: rpmts_HdrFromFdno: Header V4 DSA/SHA1 Signature, key ID 1bb943db: NOKEY
Retrieving key from https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
Importing GPG key 0x1BB943DB:
 Userid: "MariaDB Package Signing Key <package-signing-key@mariadb.org>"
 From  : https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : MariaDB-compat-10.0.28-1.el6.x86_64                                                                                                                                                                                       1/4
  Installing : MariaDB-common-10.0.28-1.el6.x86_64                                                                                                                                                                                       2/4
warning: /etc/my.cnf created as /etc/my.cnf.rpmnew
  Installing : MariaDB-client-10.0.28-1.el6.x86_64                                                                                                                                                                                       3/4
  Installing : MariaDB-server-10.0.28-1.el6.x86_64                                                                                                                                                                                       4/4
  Verifying  : MariaDB-common-10.0.28-1.el6.x86_64                                                                                                                                                                                       1/4
  Verifying  : MariaDB-compat-10.0.28-1.el6.x86_64                                                                                                                                                                                       2/4
  Verifying  : MariaDB-server-10.0.28-1.el6.x86_64                                                                                                                                                                                       3/4
  Verifying  : MariaDB-client-10.0.28-1.el6.x86_64                                                                                                                                                                                       4/4

Installed:
  MariaDB-client.x86_64 0:10.0.28-1.el6                                                                                 MariaDB-server.x86_64 0:10.0.28-1.el6

Dependency Installed:
  MariaDB-common.x86_64 0:10.0.28-1.el6                                                                                 MariaDB-compat.x86_64 0:10.0.28-1.el6

Complete!
[root@scrutinizer ~]#
I hope this helps? BTW I followed the upgrade steps exactly and I never noticed any errors on the screen.

thanks
Arne

jennm
Posts: 6
Joined: Thu Jun 09, 2016 11:36 am

Re: mysqld not running after upgrade from 15.8 -to 16.3

Post by jennm » Fri Dec 02, 2016 10:16 am

Hello Arne,

These would be our suggested steps to follow if for some reason MariaDB fails to install on a 16.3 upgrade:

Setp one: Is mysql still there? (If not skip to Step three) If so...

Code: Select all

 yum -y remove mysql mysql-server mysql-libs mysql-community-release mysql-community-libs mysql-community-common
Step two: Run this command

Code: Select all

 rpm -e mysql-community-client mysql-community-server mysql-community-release mysql-community-common mysql-community-libs
Step three: This installs MariaDB

Code: Select all

 rpm -ivh --nodeps ~plixer/scrutinizer/files/linux/MariaDB-10.0.*
Step four:

Code: Select all

 rm -f /etc/my.cnf
Step five:

Code: Select all

 cp /etc/my_plixer.cnf /etc/my.cnf
Step six:

Code: Select all

 cp /etc/init.d/mysql /etc/init.d/mysqld
Step seven:

Code: Select all

 service mysql start
Step eight: Rerun the 16.3 installer (https://files.plixer.com/archive/scruti ... r_16.3.run)

If you require further assistance please contact our support department:

*Customer Technical Support is available for service agreement holders only*

Telephone Support
207.324.8805 x 4
Available Mon - Fri 8am - 5pm Eastern Time US
(24/7 Support Contracts are Available)

or

Email Support: https://www.plixer.com/Support/customer ... pport.html

biera16
Posts: 3
Joined: Thu Dec 01, 2016 12:38 am

Re: mysqld not running after upgrade from 15.8 -to 16.3

Post by biera16 » Mon Dec 05, 2016 10:36 pm

Hi Jenn

your instructions were 100% spot on. All working again. I finally upgraded to 16.11 !!!

Also figured out that pressing CTRL-F5 cures a lot of browser weirdness after an upgrade.

Code: Select all

[root@scrutinizer bin]# ./scrut_util.exe -v

Scrutinizer 16.11.15.65721 (Tue Nov 15 19:15:27 2016)
scrut_util 16.11.15.65658 (2016-11-11 12:05:03 -0500 (Fri, 11 Nov 2016))
thanks a lot for the excellent support,

:D

Arne

effonyhor
Posts: 2
Joined: Tue May 02, 2017 8:03 am

mysqld not running after upgrade from 15 8 to 16 3

Post by effonyhor » Wed May 10, 2017 3:17 pm

Very cool. Im not much for Mustangs usually since they are so common, but that one has my respect.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest