Different values for Eth and cbQoS

Denika Performance Trender™ is a 100% web configurable view into the performance of your IT and IS resources. Denika answers: How much of the resource (network bandwidth, CPU, hard drive, etc.) is being consumed? What is the Up-Time of an important application, server and or network device? What is the Response-Time of an important application, server and or network device?

Moderators: scottr, Moderator Team

Locked
Bartman2002
Posts: 6
Joined: Tue Nov 23, 2010 2:44 pm

Different values for Eth and cbQoS

Post by Bartman2002 » Mon Jan 03, 2011 11:46 am

Hi all,

I configured QoS on a lab router, when I compare Eth and QoS (Pre & Post) values, the QoS values are slightly higher. (20%). When I deal with misconfiguration I supposed to see more traffic on Eth.... Can anyone give me the answer?

Bart

pauld
Posts: 222
Joined: Mon Jan 04, 2010 10:05 am
Location: Kennebunk, Maine
Contact:

Re: Different values for Eth and cbQoS

Post by pauld » Mon Jan 03, 2011 12:52 pm

Hello Bart,

I don't fully understand your question, so I've got a few questions for you.
I configured QoS on a lab router, when I compare Eth and QoS (Pre & Post) values, the QoS values are slightly higher. (20%). When I deal with misconfiguration I supposed to see more traffic on Eth.... Can anyone give me the answer?
Can you clarify what you mean by comparing Eth and QoS? What is Eth? Do you mean port speed?

The QoS values are slightly higher than what? From my understanding, Quality of Service is a set of bits that determine the priority of the traffic to ensure quality and reliability in conversations across the network, so I'm unsure how this can be 20% higher than what you're expecting.

Can you post a screen shot of what you're looking at?

Thanks,
Paul

Bartman2002
Posts: 6
Joined: Tue Nov 23, 2010 2:44 pm

Re: Different values for Eth and cbQoS

Post by Bartman2002 » Wed Jan 05, 2011 3:19 pm

Hi Paul

I made some screencaptures and included them as attachment. The cbQoS configuration is for outbound. See the diff. 13 / 18 K. I don't understand why the QoS value higher compared to the Eth.
Attachments
Eth.jpg
Eth.jpg (82.73 KiB) Viewed 24773 times
cbQoS.jpg
cbQoS.jpg (88.46 KiB) Viewed 24773 times

pauld
Posts: 222
Joined: Mon Jan 04, 2010 10:05 am
Location: Kennebunk, Maine
Contact:

Re: Different values for Eth and cbQoS

Post by pauld » Wed Jan 05, 2011 3:56 pm

Hi Bart,

What interfaces are your CBQoS policy applied to? The CBQoS Bytes Pre/Post report is showing how the policy matched for all the interfaces it's applied to, not just the Fa0/0 interface. It's recommended to configure CBQoS on a per-interface basis for the best QoS.

Thanks,
Paul

Bartman2002
Posts: 6
Joined: Tue Nov 23, 2010 2:44 pm

Re: Different values for Eth and cbQoS

Post by Bartman2002 » Fri Jan 07, 2011 2:18 am

Hi Paul,

Thank you for brainsharing....

cbQoS is only applied to Fa0/0

Is it possible caused by header information??

interface FastEthernet0/0
ip address 10.0.0.237 255.255.252.0
ip nbar protocol-discovery
ip flow ingress
ip flow egress
duplex full
speed 100
service-policy output Bart
!
interface FastEthernet0/1
description $ES_LAN$
ip address 192.168.1.1 255.255.255.0
ip nbar protocol-discovery
duplex full
speed 100


Bart

User avatar
tomp
Site Admin
Posts: 315
Joined: Wed Jul 27, 2005 10:53 am
Location: Sunny Sanford Maine
Contact:

Re: Different values for Eth and cbQoS

Post by tomp » Fri Jan 07, 2011 9:43 am

Hi Bart,

Can you show me your service policy and class map definitions?

What IOS version are working with?

- Tom

Bartman2002
Posts: 6
Joined: Tue Nov 23, 2010 2:44 pm

Re: Different values for Eth and cbQoS

Post by Bartman2002 » Fri Jan 07, 2011 5:38 pm

Hi Tom,

It's quite basic...


Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T4, RELEASE SOFTWARE (fc2)


class-map match-any Bart
match any

policy-map Bart
class Bart

interface FastEthernet0/0
ip address 10.0.0.237 255.255.252.0
ip nbar protocol-discovery
ip flow ingress
ip flow egress
duplex full
speed 100
service-policy output Bart

User avatar
tomp
Site Admin
Posts: 315
Joined: Wed Jul 27, 2005 10:53 am
Location: Sunny Sanford Maine
Contact:

Re: Different values for Eth and cbQoS

Post by tomp » Mon Jan 10, 2011 9:11 am

I'm starting to think you may be experiencing a Cisco bug, but I'm verifying in my lab right now.

I'm working with:

Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 15.1(3)T, RELEASE SOFTWARE (fc1).

I'll keep you posted.

Bartman2002
Posts: 6
Joined: Tue Nov 23, 2010 2:44 pm

Re: Different values for Eth and cbQoS

Post by Bartman2002 » Wed Jan 12, 2011 11:53 am

Hi Tom,

I upgraded my router to the latest 15.1(3)T and still experience the same mismatch....

Bart

User avatar
tomp
Site Admin
Posts: 315
Joined: Wed Jul 27, 2005 10:53 am
Location: Sunny Sanford Maine
Contact:

Re: Different values for Eth and cbQoS

Post by tomp » Wed Jan 19, 2011 8:52 am

Hi Bart,

I just verified that I'm also seeing a difference. Mine is closer to 100k off.

I'm going to contact TAC and see what they have to say.

- Tom

Bartman2002
Posts: 6
Joined: Tue Nov 23, 2010 2:44 pm

Re: Different values for Eth and cbQoS

Post by Bartman2002 » Sun Feb 06, 2011 3:50 pm

Looking forward to their reply.

User avatar
tomp
Site Admin
Posts: 315
Joined: Wed Jul 27, 2005 10:53 am
Location: Sunny Sanford Maine
Contact:

Re: Different values for Eth and cbQoS

Post by tomp » Wed Feb 16, 2011 4:34 pm

Hi Bart,

I haven't forgot about you. I have a TAC case open and I've been trying to connect with them.

I just viewed my trending graphs and they are now showing accurate information (withing a couple k of each other)

As you can see here if you add up all of the cbQoS and compare with the outbound port utilization, they are very close.

Are your reports still tracking apart?
cbQoS.png
cbQoS.png (172.68 KiB) Viewed 19844 times

User avatar
tomp
Site Admin
Posts: 315
Joined: Wed Jul 27, 2005 10:53 am
Location: Sunny Sanford Maine
Contact:

Re: Different values for Eth and cbQoS

Post by tomp » Wed Feb 16, 2011 4:48 pm

Hi Bart,

I have a hunch why these values are slightly different.

When we poll for cbQoS values, we grab the counter and report exactly on the counter value. When we poll for Port Utilization we poll for the counter value then divide by 300, which then makes this value an average and not an exact figure. We do this because the poller polls every 5 minutes or 300 seconds and the counter associated to port utilization is a counter that increases over time, not a gauge that reports the amount of utilization at a specific moment.

I think that Pre (1.3.6.1.4.1.9.9.166.1.15.1.1.5.$INSTANCE)/Post Policy (1.3.6.1.4.1.9.9.166.1.15.1.1.9.$INSTANCE) traffic is a gauge. We will see what TAC says, but I have a feeling this is the answer.

- Tom

User avatar
tomp
Site Admin
Posts: 315
Joined: Wed Jul 27, 2005 10:53 am
Location: Sunny Sanford Maine
Contact:

Re: Different values for Eth and cbQoS

Post by tomp » Tue Dec 06, 2011 11:14 pm

Hi Bart,

Cisco has not gotten back to me on this. They have been unable to confirm/deny this is a bug.

- Tom

Locked

Who is online

Users browsing this forum: No registered users and 1 guest